More is not better…

I just finished restoring my fave guitar last night and I decided to plug it into my POD X3 Live. I was thinking to myself that I could find out what settings I needed in order to make it as nice sounding as the Amp Designer plug-ins with Logic Pro 9. I decided to try some of the many settings that I had made, that I thought once sounded good. Sure enough, they don’t sound very good anymore. I got to a point where I had to switch patches because they were hurting my ears. That’s when I decided to cut it down to the bare essentials.

I cut out all of the effects and just went right for the amp itself. In many cases, that’s where the problem lied. Sure, there are a lot of modelled amps in my X3. However, it seems like the 25 that I have in Amp Designer really kick the stuffing out of my X3. In Logic, I hear music and harmony. In my X3, I’m hearing noise and dissonance. I don’t know if it’s me, but I seem to lack inspiration when I plug into my X3. As soon as I plug into Logic, I’m hearing musical vibrations. I can’t put my finger on it, but with the last two songs I did, I decided to use the Amp Designer and Pedalboard from Logic and loved the results. I couldn’t stop listening to “I Wanna Be…” as the guitars totally rocked out.

I may have more amp choices in my X3, but I am starting to feel like I have better amp modelling in Logic. I’m hoping I’m just missing something…

Leave a Reply

Your email address will not be published. Required fields are marked *